Home » Exchange Server 2010 » Client Connectivity » Troubleshooting Exchange Management Console (EMC) not opening (Version 2007 & 2010)

Translate:

Archives

Troubleshooting Exchange Management Console (EMC) not opening (Version 2007 & 2010)

Exchange Management Console (EMC) not opening (Version 2007 & 2010)

 

Today let’s discuss on EMC not opening

 

Error Message:

EMC1

 

Before jumping into Troubleshooting steps, first we’ll see the possible causes and Troubleshooting.

 

Possible Causes:

1: Time Synchronization

2: Connectivity (Domain & Client Machine) like below:

 

a: Time Sync Issue in between Domain and Exchange Server

b: SACL Rights missing

 

3: WinRM Issues

4: Due to IPV6

 

Step for Isolating the Issue :

 

Now First and foremost step when we come across such scenario’s is run

 

EMC Troubleshooter: EMC Troubleshooter

 

So now will discuss step by step:

 

1: Time Synchronization issue:

 

Here if youโ€™re Exchange Server Hosted on Hyper-V that is not synced to the same time source as the domain controllers which are hosted on a separate VMware ESX server. Normally the Exchange servers would still sync their time with the PDC-E for their domain but the Hyper-V integration settings were overriding this.

EMC2

Now uncheck the option Time Synchronization as shown below

EMC3

After uncheck the box then sync the time for Exchange Server and Domain Controller.

Note: Time should sync between Domain and Exchange Servers

 

2: Connectivity Issues:

 

For more info on Time Sync Issues:

a: Time-Sync with Domain and External Source

 

And do not forget to restart the Exchange Servers to get all the Services Online.

 

b: SACL Right Missing or MSExchange DSAccess Issue please follow the below article:

 

SACL Rights Misssing DSAccess Errors

 

Note: Sometimes this might occur due Network Issues.

So quick check is Open the Failover Manager and check if the DAG Object is Online, as shown below:

EMC4

 

For More Info: DAG Object Online

 

3: WinRM Issues

Now let’s see if there could be any chances to find out errors on Client Side which is causing due to WinRM.

And not letting us to open EMC, and also check if EMS (Exchange Management Shell) is also not opening.

 

If WINRM Not Installed please follow the below steps.

 

 

Steps:

1: Make sure IIS WinRM extension is installed

2: Open powershell and run command : WinRM Quickconfig

3: Open IIS go to Powershell virtual directory and check that SSL in disabled and authentication is set only to Anonymous

4: Open Windows Powershell modules.

5: Run Remove-PowershellVirtualdirectory command.

6: Run New-PowershellVirtualDirectory command.

7: IISRESET

 

 

Sometimes there will be other causes which make EMC to not letting open due Kerbauth WSMAN,

let’s see how to sort it out ๐Ÿ™‚

 

1: Launch IIS Manager (Start-> Administrative Tools -> IIS Manager)

2: Expand the server –> Sites –> Default Web Site –> Click on PowerShell

3: Under Powershell modules, make sure kerbauth module is enabled, module type is Native and Entry

 

EMC5

 

 

 

 

Type is Local. If it is not there, then enable it or register and enable it.

 

After completing the steps above, go back to your powershell prompt and restart iis by running command 2 below:

 

a: In your powershell prompt, run WinRM quickconfig hit enter and accept the changes.

b: Run iisreset

 

 

Oops still EMC not opening don’t be panic ๐Ÿ™‚ as I said there will be certain causes which will not letting us to open EMC.

 

 

letโ€™s begin follow the below steps to check .dll files or ExchagneInstall path which might causing the issue.

 

 

We will have to get into some more config files details:

 

To do that, confirm the following

 

a: The “Authenticated Users” group is added to the security property of your ClientAccess folder in C:Program FilesMicrosoftExchange ServerV14

 

b: Browse to C:Program FilesMicrosoftExchange ServerV14ClientAccessPowerShell

 

c: Make a backup of the web.config file (always make a backup before making any changes in a config file)

 

d: Open the file, find and replace File : ///%ExchangeInstallDir% with File : ///C:Program FilesMicrosoftExchange ServerV14.

 

d: At this stage, we are replacing the environmental variable found in the system properties with an absolute path. If for some reason your system couldn’t call the variables, then this should take care of the problem.

 

e: Save the file and run iisreset

 

 

4: Due to IPV6

 

It’s funny but sometimes it might help as IPV6 causing the problem.

 

Note: If Exchange Server Installed on Domain Controller DO NOT Disable IPV6. If it’s Client Machine yes we can go ahead and disable this from Registry (regedit).

 

Disabling IPV6 from Network Configuration will not help us here.

 

Technet : Disable or Re-Enable IPv6

 

Now let’s see how to disable IPV6 from registry

 

 

Method 1:

 

a: Click Start โ€“> run โ€“> regedit

 

b: Locate the following registry entry: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesTcpip6Parameters

 

EMC6

 

 

 

c: In the details pane click New and then click DWORD (32-bit) Value.

 

d: Type DisabledComponents, and then press ENTER.

 

e: Double-click DisabledComponents, and then type 0xffffffff in Hexadecimal or 4294967295 in Decimal.

 

Note: The 0xffffffff value or the 4294967295 value disables all IPv6 components except for the IPv6 loopback interface.

 

 

Method 2:

 

Open command prompt as Administrator and type the below command:

 

reg add hklmsystemcurrentcontrolsetservicestcpip6parameters /v DisabledComponents /t REG_DWORD /d 255 /f

 

EMC7

 

 

 

 

Here are some Possible causes with resolution Steps.

 

 

 

Praveen Kumar

MCTS | Exchange Server

Publisher @ Techrid.com


Leave a comment

Translate »